bug après l'intro

  • 11 Réponses
  • 113 Vues
*

Hors ligne artur205

  • Nouveau Membre
  • *
  • 12
bug après l'intro
« le: 09 juin 2018, 13:54:16 »
après l'intro il y a une fenetre qui me dit erreur dans le script loading inspecter le rapport log.txt
 

bug après l'intro
« Réponse #1 le: 09 juin 2018, 14:17:07 »
As-tu ouvert le fichier qu'il te demande d'inspecter ?
Ca pourrait être intéressant que tu nous le montres.
ln(yo) = <3
 

*

Hors ligne artur205

  • Nouveau Membre
  • *
  • 12
bug après l'intro
« Réponse #2 le: 09 juin 2018, 15:22:16 »
c' est un bloc-notes c'est écris    ---------- Erreur de script : Loading ----------
----- Type
Errno::ENOENT

----- Message
No such file or directory - Graphics/Autotiles/062-CF_Lava01

----- Position dans Loading
Ligne 1

----- Backtrace
Script : Loading | Ligne : 1 | Méthode : in `initialize'
Script : Loading | Ligne : 1 | Méthode : in `new'
Script : Loading | Ligne : 1 | Méthode : in `load_bitmap'
Script : Loading | Ligne : 1 | Méthode : in `autotile'
Script : MAPLINK | Ligne : 111 | Méthode : in `initialize'
Script : MAPLINK | Ligne : 109 | Méthode : in `each'
Script : MAPLINK | Ligne : 109 | Méthode : in `initialize'
Script : Scene_Map | Ligne : 192 | Méthode : in `new'
Script : Scene_Map | Ligne : 192 | Méthode : in `transfer_player'
Script : Scene_Map | Ligne : 55 | Méthode : in `alias_update'
Script : Scene_Map | Ligne : 46 | Méthode : in `loop'
Script : Scene_Map | Ligne : 59 | Méthode : in `alias_update'
Script : MAPPANEL | Ligne : 90 | Méthode : in `update'
Script : Scene_Map | Ligne : 25 | Méthode : in `main'
Script : Scene_Map | Ligne : 19 | Méthode : in `loop'
Script : Scene_Map | Ligne : 30 | Méthode : in `main'
Script : Main | Ligne : 57
 

bug après l'intro
« Réponse #3 le: 09 juin 2018, 15:30:42 »
Si tu connais un minimum d'anglais, ou si tu tentais, au moins, d'observer le log, tu verrais ceci
Citer
No such file or directory - Graphics/Autotiles/062-CF_Lava01
Ce qui veut dire en français :
Citer
Ne trouve pas le fichier ou l'emplacement du fichier appelé : Graphics/Autotiles/062-CF_Lava01
(c'est simplifié mais comme ça c'est plus clair)
Tu n'as donc plus qu'à trouver ce fichier et le mettre dans ton dossier Graphics/Autotiles

*

Hors ligne artur205

  • Nouveau Membre
  • *
  • 12
bug après l'intro
« Réponse #4 le: 09 juin 2018, 15:45:09 »
mais non il est introuvable et ce n'est pas un petit truc comme ça qui va faire bugger mon jeu
 

bug après l'intro
« Réponse #5 le: 09 juin 2018, 16:03:11 »
.__. C'est ce qui fait bugguer ton jeu et s'il est introuvable, je te conseille de vérifier la configuration des tilesets dans laquelle a été déclaré l'autotile. Il faudra alors le retirer de la liste des autotiles

*

En ligne SMB64

bug après l'intro
« Réponse #6 le: 09 juin 2018, 16:06:09 »
Si le jeu tente d'afficher une image mais que le fichier image n'existe pas, il ne peut pas la construire dans le jeu, donc le jeu plante. C'est logique  :3
Credit stickers avatar : https://onainitsuj.deviantart.com/
Credit background avatar : https://orangedroplet.deviantart.com/
 
Utilisateurs ayant remercié ce post : yyyyj

*

Hors ligne artur205

  • Nouveau Membre
  • *
  • 12
bug après l'intro
« Réponse #7 le: 09 juin 2018, 16:24:34 »
.__. C'est ce qui fait bugguer ton jeu et s'il est introuvable, je te conseille de vérifier la configuration des tilesets dans laquelle a été déclaré l'autotile. Il faudra alors le retirer de la liste des autotiles
j'avais dit que je suis nouveau.
 

*

En ligne SMB64

bug après l'intro
« Réponse #8 le: 09 juin 2018, 16:37:08 »
Non, mais le forum fait bien son boulot et nous indique que tu es effectivement un nouveau membre ^^
Mais comme l'a dit mon collègue, soit tu dois retrouver l'image demandée et la mettre dans le bon dossier (Graphics/Autotiles /), soit tu dois supprimer les appels à cet image dans les scripts du jeu.
C'est étrange que t'aie des appels à des images n'existant pas si tu as pris les bons fichiers sur la page de download de PSDK.
Credit stickers avatar : https://onainitsuj.deviantart.com/
Credit background avatar : https://orangedroplet.deviantart.com/
 

bug après l'intro
« Réponse #9 le: 09 juin 2018, 16:58:49 »
Il n'utilise pas PSDK.
Il a juste à configurer correctement ses tilesets pour que ce bug n'apparaisse plus.
ln(yo) = <3
 
Utilisateurs ayant remercié ce post : yyyyj

*

Hors ligne artur205

  • Nouveau Membre
  • *
  • 12
bug après l'intro
« Réponse #10 le: 09 juin 2018, 17:03:57 »
je suis sur que c'est a cause des maps que j'ai télécharger
 

*

Hors ligne Rey

  • Juste un homme qui traîne sur PW. (et qui traîna sur CSP et PSP)
  • Membre
  • **
  • 60
  • Remercié: 43 fois
  • Rey, à votre service !
bug après l'intro
« Réponse #11 le: 09 juin 2018, 17:39:49 »
Si tu as téléchargé des maps, et que tu ne possèdes pas les ressources nécessaires à la map pour l'afficher (autotiles, tilesets, etc...) t'étonnes pas que ça ne fonctionne pas.
Je répète ce que mes collègues ont dit au dessus : vérifie tes ressources et vois si tu as TOUTES les ressources nécessaires.

Petit aparté, tu as dit avoir téléchargé les maps... J'espère que tu ne les as pas prises d'un autre projet sans même avoir une autorisation de la part du créateur, parce que si c'est le cas, tu ne vas pas faire long feu ici. (Si ce n'est pas le cas, tant mieux, mais si c'est le cas, je te conseille vivement de les supprimer et d'apprendre à faire tes propres maps, surtout si tu comptes par la suite présenter un projet ici. ;) )
 
Utilisateurs ayant remercié ce post : yyyyj